aboutsummaryrefslogtreecommitdiffstats
path: root/initscripts.spec
diff options
context:
space:
mode:
Diffstat (limited to 'initscripts.spec')
-rw-r--r--initscripts.spec108
1 files changed, 96 insertions, 12 deletions
diff --git a/initscripts.spec b/initscripts.spec
index 3d91ac3f..30731caa 100644
--- a/initscripts.spec
+++ b/initscripts.spec
@@ -4,7 +4,7 @@
Summary: The inittab file and the /etc/init.d scripts
Name: initscripts
-Version: 9.25
+Version: 9.34
# ppp-watch is GPLv2+, everything else is GPLv2
License: GPLv2 and GPLv2+
Group: System Environment/Base
@@ -27,8 +27,8 @@ Requires: upstart-sysvinit
%endif
%endif
%if %{_with_systemd}
-Conflicts: systemd < 12-1
-Conflicts: systemd-units < 12-1
+Conflicts: systemd < 23-1
+Conflicts: systemd-units < 23-1
%if ! %{_with_upstart}
Requires: systemd-sysvinit
%endif
@@ -54,6 +54,8 @@ Conflicts: e2fsprogs < 1.15
# http://bugzilla.redhat.com/show_bug.cgi?id=252973
Conflicts: nut < 2.2.0
Conflicts: NetworkManager < 1:0.8.0-12.git20100504
+Conflicts: libselinux < 2.1.0
+Conflicts: ipsec-tools < 0.8.0-2
Obsoletes: hotplug <= 3:2004_09_23-10.1
Requires(pre): /usr/sbin/groupadd
Requires(post): /sbin/chkconfig, coreutils
@@ -125,6 +127,11 @@ rm -f \
%endif
touch $RPM_BUILD_ROOT/etc/crypttab
+chmod 600 $RPM_BUILD_ROOT/etc/crypttab
+
+rm -f $RPM_BUILD_ROOT/etc/rc.d/rc.local $RPM_BUILD_ROOT/etc/rc.local
+touch $RPM_BUILD_ROOT/etc/rc.d/rc.local
+chmod 755 $RPM_BUILD_ROOT/etc/rc.d/rc.local
%pre
/usr/sbin/groupadd -g 22 -r -f utmp
@@ -203,8 +210,6 @@ rm -rf $RPM_BUILD_ROOT
/etc/sysconfig/network-scripts/ifdown-eth
/etc/sysconfig/network-scripts/ifup-ipv6
/etc/sysconfig/network-scripts/ifdown-ipv6
-/etc/sysconfig/network-scripts/ifup-ipsec
-/etc/sysconfig/network-scripts/ifdown-ipsec
/etc/sysconfig/network-scripts/ifup-sit
/etc/sysconfig/network-scripts/ifdown-sit
/etc/sysconfig/network-scripts/ifup-tunnel
@@ -236,15 +241,15 @@ rm -rf $RPM_BUILD_ROOT
%dir /etc/rc.d
%dir /etc/rc.d/rc[0-9].d
%config(missingok) /etc/rc.d/rc[0-9].d/*
-%exclude /etc/rc.d/rc[0-9].d/*reboot
-%exclude /etc/rc.d/rc[0-9].d/*halt
+%exclude /etc/rc.d/rc[0-9].d/*
/etc/rc[0-9].d
%dir /etc/rc.d/init.d
-/etc/rc.local
/etc/rc.d/init.d/*
%exclude /etc/rc.d/init.d/halt
+%exclude /etc/rc.d/init.d/killall
%exclude /etc/rc.d/init.d/reboot
-%config(noreplace) /etc/rc.d/rc.local
+%exclude /etc/rc.d/init.d/single
+%ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/rc.d/rc.local
%config(noreplace) /etc/sysctl.conf
%exclude /etc/profile.d/debug*
/etc/profile.d/*
@@ -262,10 +267,7 @@ rm -rf $RPM_BUILD_ROOT
%attr(2755,root,root) /sbin/netreport
/lib/udev/rules.d/*
%exclude /lib/udev/rules.d/10-console.rules
-%exclude /lib/udev/rules.d/88-clock.rules
/lib/udev/rename_device
-/lib/udev/console_init
-/lib/udev/console_check
/sbin/service
/sbin/ppp-watch
%{_mandir}/man*/*
@@ -305,6 +307,8 @@ rm -rf $RPM_BUILD_ROOT
/etc/rc.d/rc
/etc/rc.d/rc.sysinit
/lib/udev/rules.d/*
+/lib/udev/console_init
+/lib/udev/console_check
%files -n debugmode
%defattr(-,root,root)
@@ -312,6 +316,86 @@ rm -rf $RPM_BUILD_ROOT
/etc/profile.d/debug*
%changelog
+* Tue Oct 25 2011 Bill Nottingham <notting@redhat.com> - 9.34-1
+- read locale.conf if it exists (#706756)
+- ifdown: fix logic error with removing arp_ip_target (#745681)
+
+* Wed Oct 12 2011 Bill Nottingham <notting@redhat.com> - 9.33-1
+- netconsole: only use the first ARP response (#744309, <doug.knight@karmix.org>)
+- udev/rules.d/88-clock.rules: drop this entirely, as it causes issues in conjunction with systemd
+- init.d/network: be less picky about ifcfg file names. (#742276)
+- /sbin/service: do not check for the existence of a systemd unit before redirecting (<mschmidt@redhat.com>)
+- init.d/functions: only run consoletype if connected to something that's console-ish. (#657869)
+
+* Fri Sep 2 2011 Bill Nottingham <notting@redhat.com> - 9.32-1
+- prefdm: if exec() of all DMs fails, call 'plymouth quit' (#735215)
+- %%ghost rc.local (but leave it around on upgrade) (#734268)
+- ifup: support random bridging options via BRIDGING_OPTS (#734045, #665378)
+- selinuxfs moved to /sys/fs, handle it (#733759)
+- netfs/fedora-storage-init: call multipath and kpartx with -u (#733437)
+- plymouth lives in /bin (#702814)
+- drop fedora-autoswap
+- ifdown-eth: fix dhclient pid file for IPv6 (#729292, <daveg@dgit.ndo.co.uk>)
+- move some more things to the legacy subpackage
+- netfs: don't mount gfs2 here (#689593)
+- readonly-root: add an empty CLIENTSTATE defintion (#725476)
+- drop sysinit hack/unhack
+- ifup-eth: allow more options in ETHTOOL_OPTS (#692410, #693583)
+- rwtab: update for systemd (#704783)
+- debug.csh: fix for latest csh
+- update translations: eu_ES, hy, ku, lo, my, wa
+
+* Tue Jun 21 2011 Bill Nottingham <notting@redhat.com> - 9.31-1
+- remove ifup/ifdown-ipsec; they're now in ipsec-tools
+- rc.sysinit: start udev by hand, start_udev is no more (#714531)
+- ifup-aliases: if IPv6 is configured on the alias, configure it. (#583409)
+- ifup-eth: ensure DHCP_HOSTNAME is a short hostname, seed it from HOSTNAME if needed. (#697877)
+- network-functions: override NETMASK from PREFIX where specified (#705367, <mpoole@redhat.com>)
+- exclude single symlink from main package (#705457)
+- network: VLAN, etc. interfaces can be slaves; check for being a slave first. (#703475)
+- network: use LC_ALL=C when calling sed. (https://bugs.mageia.org/show_bug.cgi?id=1216, via <sander.lepik@eesti.ee>)
+- functions: (umount_loop) fuser -k defaults to -9; set the initial pass to kill -15. (#703457)
+- init.d/halt: don't match filesystem types in hostnames (#703203, <jmueller@data-tronics.com>)
+
+* Wed Apr 27 2011 Bill Nottingham <notting@redhat.com> - 9.30-1
+- ifup-eth: handle IPADDRx correctly for static addresses (#697838)
+- systemd: fix storage setup service after cryptsetup.target (#699918)
+- prefdm: tweak how plymouth is quit in the gdm/kdm case (<rstrode@redhat.com>)
+- support /etc/hostname as an override for hostname in /etc/sysconfig/network
+- init.d/single: only ship this in -legacy
+- network-functions: fix IPADDRx index handling (<jklimes@redhat.com>)
+- ifup/down-eth: properly handle apr_ip_target, when used with module options (#604669, <harald@redhat.com>)
+- ifup-eth: ensure bond exists before bringing up slaves (#694501)
+
+* Wed Apr 06 2011 Bill Nottingham <notting@redhat.com> - 9.29-1
+- systemd: add a storage setup service after cryptsetup.target (#692198)
+- fix /.autorelabel handling (<mschimdt@redhat.com>)
+- don't explicitly disallow IPv6 aliases (#583409, #612877)
+- netfs: don't print errors if mdadm isn't installed. (#692187)
+- ifup-eth: use /run/initramfs rather then /dev/.run/initramfs (<harald@redhat.com>)
+
+* Fri Mar 25 2011 Bill Nottingham <notting@redhat.com> - 9.28-1
+- add some generic network logging, port scripts to it (#507515, #653630)
+- add an error when setting the gateway fails (#672202)
+
+* Thu Mar 17 2011 Bill Nottingham <notting@redhat.com> - 9.27-1
+- init.d/functions: fix mishandled argument to fstab-decode. (#685137)
+- support ipv6 routing rules, merge route/rule code (#680872, <tobiasoed@hotmail.com>)
+- autorelabel.service, loadmodules.service: fix conditions so that they operate as OR, not AND. (#684125)
+
+* Thu Mar 10 2011 Bill Nottingham <notting@redhat.com> - 9.26-1
+- network-functions: fix check for unmanaged devices (#670154)
+- ifup-eth: also check /dev/.run/initramfs (<harald@redhat.com>)
+- systemd: execute fedora-sysinit-unhack after sysinit.target (<arvidjaar@gmail.com>)
+- init.d/functions: don't do force/lazy umount for the first nfs umount. (#676851, <jlayton@redhat.com>)
+- further sysctl.d fixes (#593211)
+- init.d/functions: make killproc more granular when delay is passed. (#428029, <xjakub@fi.muni.cz>)
+- ifup: add GVRP support (#597598, <tomek@jot23.org>)
+- init.d/functions: add support for noauto crypt devices, to mirror systemd
+- documentation updates
+- bash cleanups (<ville.skytta@iki.fi>)
+- ifup: remove network device naming requirement from VLAN devices (#462095, <Matt_Domsch@dell.com>)
+
* Fri Feb 25 2011 Bill Nottingham <notting@redhat.com> - 9.25-1
- remove 'Red Hat Linux' references from sysctl.conf* (<ville.skytta@iki.fi>)
- rc.sysinit: add support for sysctl.d (#593211, <martin@laptop.org>)