aboutsummaryrefslogtreecommitdiffstats
path: root/rpmbuildupdate.spec
diff options
context:
space:
mode:
authorGuillaume Rousse <guillomovitch@mandriva.org>2005-10-06 15:39:19 +0000
committerGuillaume Rousse <guillomovitch@mandriva.org>2005-10-06 15:39:19 +0000
commitc6bdd1f5e7b926f5266fc6b580050c25367a6482 (patch)
tree8d6b38a9adff6382888b3bd0bcfb448fc719fd46 /rpmbuildupdate.spec
parente41b77a92d01b2c2fb9c946649e4b1b8d13e57a9 (diff)
downloadbootsplash-c6bdd1f5e7b926f5266fc6b580050c25367a6482.tar
bootsplash-c6bdd1f5e7b926f5266fc6b580050c25367a6482.tar.gz
bootsplash-c6bdd1f5e7b926f5266fc6b580050c25367a6482.tar.bz2
bootsplash-c6bdd1f5e7b926f5266fc6b580050c25367a6482.tar.xz
bootsplash-c6bdd1f5e7b926f5266fc6b580050c25367a6482.zip
split rpmbuildupdate out
Diffstat (limited to 'rpmbuildupdate.spec')
-rw-r--r--rpmbuildupdate.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/rpmbuildupdate.spec b/rpmbuildupdate.spec
new file mode 100644
index 0000000..6a4ed17
--- /dev/null
+++ b/rpmbuildupdate.spec
@@ -0,0 +1,43 @@
+%define name rpmbuildupdate
+%define version 0.5
+%define release %mkrel 1
+
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Summary: Helps you build up to date RPMs
+License: GPL
+Group: Development/Other
+Source0: %{name}-%{version}.tar.bz2
+Source1: %{name}.bash-completion.bz2
+BuildArch: noarch
+Requires: wget
+Buildroot: %{_tmppath}/%{name}-%{version}
+Conflicts: rpm-rebuilder <= 0.25-1mdk
+
+%description
+
+%prep
+bzcat %{SOURCE0} > %{name}
+bzcat %{SOURCE1} > %{name}.bash_completion
+
+%build
+
+%install
+rm -rf %{buildroot}
+install -d -m 755 %{buildroot}%{_bindir}
+install -d -m 755 %{buildroot}%{_sysconfdir}/bash_completion.d
+install -m 755 %{name} %{buildroot}%{_bindir}
+install -m 644 %{name}.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/%{name}
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-,root,root)
+%{_bindir}/%{name}
+%{_sysconfdir}/bash_completion.d/%{name}
+
+%changelog
+* Thu Oct 06 2005 Guillaume Rousse <guillomovitch@mandriva.org> 0.4-1mdk
+- first individual release